image0In diesem Artikel habe ich beschrieben wie man den Simfy-Player in der  64bit Version installiert. Mit Ubuntu 11.10 scheint das nicht mehr so ganz zu funktionieren.

Das System zeigt nicht erfüllbare Abhängigkeiten an wenn die derzeit verfügbare AdobeAir-Version installiert ist. Was mich verwundert, da sich eigentlich nichts geändert hat und das Programm an sich ohne Probleme läuft. Vielleicht reicht es wenn man an den Befehl bei der Installation  —ignore-depends anhängt und der ganze Befehl dann so aussieht:
sudo dpkg --force-architecture --force-depends --ignore-depends -i simfy_VERSION.deb
Geht das nicht kann man es wie frantzen machen und die deb-Datei selbst bearbeiten. In der Control-Datei muss zusätzlich zur Architektur bei den Abhängigkeiten die Adobeair-version auf die aktuelle ändern.

In meinem Fall sieht die Datei dann so aus:

Package: simfy
Version: 1.6.0
Section: Applications
Priority: extra
Architecture: all
Source: simfy
Maintainer: simfy GmbH
Description: <>
Pre-Depends: adobeair (>= 1:2.6.0.19170)
Installed-Size: 2796

Wem das zu mühsam ist, der kann die von mir so veränderte Datei benutzen: simfy_1_6_0_64bit.deb

Update: Version auf 1.6.0 aktualisiert